ToolRunner Documentation


Table of Contents

1. Introduction to ToolRunner
1.1. What is ToolRunner?
1.1.1. ToolRunner Features and Utilities
1.1.2. How ToolRunner Finds Packages
1.2. Starting ToolRunner
1.2.1. Windows
1.2.2. macOS
1.3. The ToolRunner GUI
1.3.1. FileList Area
1.3.2. Execution Area
1.4. Using ToolRunner
1.4.1. Add Files
1.4.2. Run the Process
1.4.3. Check Results
2. Supported File Types
2.1. .pro
2.2. .mldoc
2.3. .mlinstall
2.4. .mlbuild
3. Main Menu
3.1. File Menu
3.1.1. Add Files from Directory...
3.1.2. Add Files from Packages...
3.1.3. Add All Packages
3.1.4. Recent Files
3.1.5. Load FileList...
3.1.6. Save all Files to FileList
3.1.7. Save Selected Files to FileList
3.1.8. Clear FileList
3.1.9. Preferences...
3.1.10. Quit
3.2. Show Menu
3.2.1. Show All Files
3.2.2. Hide Deselected Files
3.3. Extras Menu
3.3.1. Check for Required Tools
3.3.2. Open Package Manager...
3.3.3. Remove Ignored Files (Master Builder)
4. Command Line Options
5. Troubleshooting
5.1. Windows

List of Figures

1.1. Adding ToolRunner to the Dock
1.2. ToolRunner Main Window
1.3. File List Button Menu
1.4. Filter
1.5. Run Button Menu
2.1. .pro Context Menu
2.2. Dependency Graph for the an Example Project
2.3. Dependency Graph for Multiple Example Projects
2.4. Profiles Error Viewer
2.5. .mldoc Context Menu
2.6. .mlinstall Context Menu
2.7. .mlbuild Context Menu
3.1. File Menu
3.2. Package Loader
3.3. ToolRunner Preferences
3.4. Show Menu
3.5. Extras Menu
3.6. External Tools Check
3.7. Package Manager